
 

 

 

 
 
 
 
 
 

REPORT ON SKILL ENHANCEMENT LAB 
INTERNET OF THINGS (IOT) LAB 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



PREFACE 

 

This  IOT  lab  is intended to teach the design and analysis of IOT systems. To introduce the 

terminology, technology and its applications of IOT. To introduce the Raspberry PI platform, 

that is widely used in IoT applications. To introduce the implementation of web-based 

services on IoT devices. The manual contains the exercise programs and their solution for 

easy & quick understanding of the students. We hope that this practical manual will be 

helpful for students of CSE,ECE,ISE branches for understanding the subject from the point of 

view of applied aspects 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



DEPARTMENT OF ELECTRONICS AND COMMUNICATION 
ENGINEERING 

 

ABOUT THE DEPARTMENT 

 

Vision: 

Empowering the students by giving exposure on current technologies, multiple research and 

innovation for developing dependable technologies and socially responsible engineers in the 

field of Electronics and Communication Engineering. 

 

Mission: 

1. Providing strong conceptual based teaching learning methodology to achieve excellent 

skill sets in design and develop. 

2. Impart knowledge in emerging areas through Industry interactions, technical talks and 

seminars. 

3. Motivating graduates to become entrepreneurs. 

4. By imbibing human values and ethics to make them socially responsible professionals. 

 

 

 

 

 

 

 

 

 

 

 



LIST OF EXPERIMENTS 

 
Sl No 

 
List of Experiments 

Introduction to Arduino board & Sensors 

 Part-A 

1 Turning LED On/Off using Arduino 

 
2 

 
Turning Multiple LED On/Off using Arduino 

3 Interfacing Switch (push button)-LED using Arduino 

4 Ultrasonic Sensor using Arduino 

5 Ultrasonic Sensor-LED Interface using Arduino 

6 DC motor for Fan control using IR sensor using Arduino 

7 Door Sensor using Arduino 

8 Touch Sensor using Arduino 

 Part-B 

9 LCD Display using Arduino 

10 Moisture Sensor using Arduino 

11 Flame Sensor using Arduino 

12 LDR Sensor using Arduino 

13 Humidity Sensor using Arduino 

14 Smoke sensor using Arduino 

15 Water level sensor using Arduino 

 

 

 

 

 

 

 

 



Year Course Name No. of participants 

2023-2024 Internet of Things (IOT) lab 63 (ISE) + 50 (ECE+CE+ME) 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



Arduino 

Arduino is an open-source electronics platform based on easy-to-use hardware 
and software. Arduino boards are able to read inputs - light on a sensor, a finger 
on a button, or a Twitter message - and turn it into an output - activating a motor, 
turning on an LED, publishing something online. You can tell your board what to 
do by sending a set of instructions to the microcontroller on the board. To do so 
you use the Arduino programming language (based on Wiring), and the 
Arduino Software (IDE), based on Processing. 

 
 
 

Arduino Uno Board 

 
 

The Arduino software is easy-to-use for beginners, yet flexible enough for 
advanced users. It runs on Mac, Windows, and Linux. Teachers and students use 
it to build low cost scientific instruments, to prove chemistry and physics 
principles, or to get started with programming and robotics. Arduino also 
simplifies the process of working with microcontrollers. 

Power USB 

Arduino board can be powered by using the USB cable from your computer. All 
you need to do is connect the USB cable to the USB connection 

Power button 

Arduino boards can be powered directly from the AC mains power supply by 
connecting it to the Jack of Power button. 

 

 



  Voltage Regulator 

The function of the voltage regulator is to control the voltage given to the Arduino board 
and stabilize the DC voltages used by the processor and other elements. 

Crystal Oscillator 

The crystal oscillator helps Arduino in dealing with time issues. How does Arduino 
calculate t ime? The answer is, by using the crystal oscillator. The number printed on top 
of the Arduino crystal is 16.000H9H. It tells us that the frequency is 16,000,000 Hertz or 
16 MHz. 

Arduino Reset 

You can reset your Arduino board, i.e., start your program from the beginning. You can 
reset the UNO board in two ways. First, by using the reset button on the board. Second, 
you can connect an external reset button to the Arduino pin labelled RESET 

AREF 

AREF stands for Analog Reference. It is sometimes, used to set an external 
reference voltage (between 0 and 5 Volts) as the upper limit for the analog input pins. 

TX and RX LEDs 

On your board, you will find two labels: TX (transmit) and RX (receive). They appear in 
two places on the Arduino UNO board. First, at the digital pins 0 and 1, to indicate the 
pins responsible for serial communication. Second, the TX and RX led. The TX led 
flashes with different speed while sending the serial data. The speed of flashing depends 
on the baud rate used by the board. RX flashes during the receiving process. 

Digital I/O 

The Arduino UNO board has 14 digital I/O pins (of which 6 provide PWM (Pulse Width 
Modulation) output. These pins can be configured to work as input digital pins to read 
logic values (0 or 1) or as digital output pins to drive different modules like LEDs, 
relays, etc. The pins labeled “~” can be used to generate PWM. 

Power LED indicator 

This LED should light up when you plug your Arduino into a power source to indicate 
that your board is powered up correctly. If this light does not turn on, then there is 
something wrong with the connection. 

ICSP pin 

Mostly, ICSP is a tiny programming header for the Arduino consisting of MOSI, MISO, 
SCK, RESET, VCC, and GND. It is often referred to as an SPI (Serial Peripheral 
Interface), which could be considered as an "expansion" of the output. Actually, you are 
slaving the output device to the master of the SPI bus. 

Analog pins 

The Arduino UNO board has six analog input pins A0 through A5. These pins can read the 
signal from an analog sensor like the humidity sensor or temperature sensor and convert it 
into a digital value that can be read by the microprocessor. 

Pins (3.3, 5, GND, Vin) 



 3.3V (6) − Supply 3.3 output volt 

 5V (7) − Supply 5 output volt 

 Most of the components used with Arduino board works fine with 3.3 volt and 5 
volt. 

 GND (8) (Ground) − There are several GND pins on the Arduino, any of which 
can be used to ground your circuit. 

 Vin (9) − This pin also can be used to power the Arduino board from an external 
power source, like AC mains power supply. 

Main microcontroller 

Each Arduino board has its own microcontroller. You can assume it as the brain of your 
board. The main IC (integrated circuit) on the Arduino is slightly different from board to 
board. The microcontrollers are usually of the ATMEL Company. You must know what 
IC your board has before loading up a new program from the Arduino IDE. 

 
 
It offers some advantages over other systems: 

 
 Inexpensive

 Cross-platform

 Simple, clear programming environment

 Open source and extensible software

 Open source and extensible hardware

 
Arduino UNO board is used in the following applications. 

 Weighing Machines.

 Traffic Light Count Down Timer.

 Parking Lot Counter.

 Embedded systems.

 Home Automation.

 Industrial Automation.

 Medical Instrument.

 Emergency Light for Railways.

 
After learning about the main parts of the Arduino UNO board, we are ready to learn how 
to set up the Arduino IDE. Once we learn this, we will be ready to upload our program on 
the Arduino board. 

In this section, we will learn in easy steps, how to set up the Arduino IDE on our computer 
and prepare the board to receive the program via USB cable. 

 

Step 1 − First you must have your Arduino board and a USB cable. In case you use Arduino 



UNO, Nano, Arduino Mega 2560, or Diecimila, you will need a standard USB cable (A plug 
to B plug), the kind you would connect to a USB printer as shown in the following image. 

 

 

 

Step 2 − Download Arduino IDE Software. 

You can get different versions of Arduino IDE from the Download page on the Arduino 
Official website. You must select your software, which is compatible with your operating 
system (Windows, IOS, or Linux). After your file download is complete, unzip the file. 

 

 
 

 
Step 3 − Power up your board. 

The Arduino Uno, Mega, Duemilanove and Arduino Nano automatically draw power 
from either, the USB connection to the computer or an external power supply. If you are 
using an Arduino Diecimila, you have to make sure that the board is configured to draw 
power from the USB connection. The power source is selected with a jumper, a small piece 
of plastic that fits onto two of the three pins between the USB and power jacks. Check that 
it is on the two pins closest to the USB port. 

Connect the Arduino board to your computer using the USB cable. The green power LED 
(labeled PWR) should glow. 

Step 4 − Launch Arduino IDE. 

After your Arduino IDE software is downloaded, you need to unzip the folder. Inside the 
folder, you can find the application icon with an infinity label (application.exe). Double-click 
the icon to start the IDE. 



 

Step 5 − Open your first project. 

Once the software starts, you have two options − 
 

 Create a new project. 

 Open an existing 

project example. To create a 

new project, select File → 

New. 
 

 
 
 
 



To open an existing project example, select File → Example → Basics → Blink. 
 

 
 
 
we are selecting just one of the examples with the name Blink. It turns the LED on and 
off with some time delay. You can select any other example from the list. 

Step 6 − Select your Arduino board. 

To avoid any error while uploading your program to the board, you must select the correct 
Arduino board name, which matches with the board connected to your computer. 

Go to Tools → Board and select your board. 



 

Here, we have selected Arduino Uno board according to our tutorial, but you must select 
the name matching the board that you are using. 

Step 7 − Select your serial port. 

Select the serial device of the Arduino board. Go to Tools → Serial Port menu. This is likely 
to be COM3 or higher (COM1 and COM2 are usually reserved for hardware serial ports). To 
find out, you can disconnect your Arduino board and re-open the menu, the entry that 
disappears should be of the Arduino board. Reconnect the board and select that serial port. 

 

 

 

 

 

 

 

 

 
 



 

Step 8 − Upload the program to your board. 

Before explaining how we can upload our program to the board, we must demonstrate 
the function of each symbol appearing in the Arduino IDE toolbar. 

 

 
 
 
A − Used to check if there is any 

compilation error. B − Used to upload 

a program to the Arduino board. C − 

Shortcut used to create a new sketch. 

D − Used to directly open one of the 

example sketch. E − Used to save your 

sketch. 

F − Serial monitor used to receive serial data from the board and send the serial data to the 
board. 



Now, simply click the "Upload" button in the environment. Wait a few seconds; 
you will see the RX and TX LEDs on the board, flashing. If the upload is 
successful, the message "Done uploading" will appear in the status bar. 

Note − If you have an Arduino Mini, NG, or other board, you need to press the 
reset button physically on the board, immediately before clicking the upload 
button on the Arduino Software. 

 

What are Libraries? 

 
Libraries are a collection of code that makes it easy for you to connect to a 
sensor, display, module, etc. For example, the Liquid Crystal I2C library makes 
it easy to talk to character LCD displays. 

 
There are thousands of libraries available for download directly through the 
Arduino IDE, and you can find all of them listed at the Arduino Library Reference. 

 

Installing Libraries 

 
This library should be already downloaded to the Arduino IDE. Go to the Sketch 
menu >> Include Library >> Library Manager. In the top right text box, type in 
LiquidCrystal I2C then look for the LiquidCrystal I2C Library. Once you find the 
library click on it, select the latest version and hit install. Wait for the IDE to 
install the new library. Downloading may take time depending on your 
connection speed. Once it has finished, an Installed tag should appear. 

 
 

Downloading may take time depending on your connection speed. Once it has finished, an 
Installed tag should appear. 
 



Sensors and Actuators 

 
We live in a World of Sensors. You can find different types of Sensors in our 
homes, offices, cars etc. working to make our lives easier by turning on the lights 
by detecting our presence, adjusting the room temperature, detect smoke or fire, 
make us delicious coffee, open garage doors as soon as our car is near the door 
and many other tasks. All these and many other automation tasks are possible 
because of Sensors. 

 

Sensors-A sensor is a device that measures physical input from its environment 
and converts it into data (electrical quantity) that can be interpreted by either a 
human or a machine. 

 
 
 

 
 

                       Fig:Sensors and actuators block diagram 

   

Actuators-An actuator is a part of a device or machine that helps it to achieve 
physical movements by converting energy, often electrical, air, or hydraulic, into 
mechanical force. Actuators are present in almost every machine around us, from simple 
electronic access control systems, the vibrator on your mobile phone and household 
appliances to vehicles, industrial devices, and robots. Common examples of actuators 
include electric motors, stepper motors, jackscrews, electric muscular stimulators in 
robots, etc. 

 
 
Classification of Sensors 

 
In the first classification of the sensors, they are divided in to Active and Passive. Active 
Sensors are those which require an external excitation signal or a power signal. Passive 
Sensors, on the other hand, do not require any external power signal and directly 
generates output response. 



 

The other type of classification is based on the means of detection used in the sensor. 
Some of the means of detection are Electric, Biological, Chemical, and Radioactive etc. 

 

The next classification is based on conversion phenomenon i.e., the input and the output. 
Some of the common conversion phenomena are Photoelectric, Thermoelectric, 
Electrochemical, Electromagnetic, Thermo-optic, etc. 

 

The final classification of the sensors are Analog and Digital Sensors. Analog Sensors 
produce an analog output i.e., a continuous output signal (usually voltage but sometimes 
other quantities like Resistance etc.) with respect to the quantity being measured. Digital 
Sensors, in contrast to Analog Sensors, work with discrete or digital data. The data in 
digital sensors, which is used for conversion and transmission, is digital in nature. 

 
 
Different Types of Sensors 

 
The following is a list of different types of sensors that are commonly used in various 
applications. All these sensors are used for measuring one of the physical properties like 
Temperature, Resistance, Capacitance, Conduction, Heat Transfer etc. 

 

1. Temperature Sensor 
2. Proximity Sensor 
3. Accelerometer 
4. IR Sensor (Infrared Sensor) 
5. Pressure Sensor 
6. Light Sensor 
7. Ultrasonic Sensor 
8. Smoke, Gas and Alcohol Sensor 
9. Touch Sensor 

10. Humidity Sensor 
11. Solar cell sensor 
12. Metal detector sensor 
13. Soil Moisture Sensor 
14. Heartbeat Sensor 
15. Microphone (Sound Sensor) 
16. Tilt Sensor 
17. Water Flow and Level Sensor 
18. PIR (passive infrared )Sensor 
19. Rain Sensor 
20. Oil moisture Sensor 
21. Real time clock Sensor 
22. Vibration Sensor 

 



 

 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



COURSE OUTCOMES: 

Course outcomes (Course Skill Set):  

At the end of the course the student will be able to:  

 

No. DESCRIPTION 

CO1 Understand internet of Things and its hardware and software components 

CO2 Interface I/O devices, sensors & communication modules 

CO3 Remotely monitor data and control devices 

CO4 Develop real life IoT based projects 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



GALLERY 

 

 

 

 

 

 

 



 

 

 



 

 


